I can't find my post after getting a notification of reply to my question. I click on the title of the post in the email message and it sends me to https://www.EnglishForward.com/ . It doesn't send me to my post which it used to be. The change is really impracticable and is not workable to me.

Try clearing your internet cache/cookies in your browser. That should solve the problem.

When I click on the subject title on this one in the notification email message, it sent me straight to this post of mine. I try the other one again on a different computer in a public library today but the problem is the same so I don't think it has anything to do with cache and cookie. I tried to open the other one on my own computer at home yesterday when the problem happened. Anyway I can't clear cache and cookie of this computer in a public library because we can't access it.

By the way, I can also find this one only after I click on the message notification from the bell on the top left corner. However it doesn't work when I do that on the other one.

Students: Are you brave enough to let our tutors analyse your pronunciation?

The notification for this post being https://www.EnglishForward.com/user/notification-24337892.htm sends me straight to this place.

The other one being https://www.EnglishForward.com/user/notification-24337354.htm sends me to https://www.EnglishForward.com/ only. I copy and paste the link to Firefox and Google Chrome as well as Internet Explorer and they all have the same problem.

Could you please try the latter link for me!

It sends me to my notifications.

But did you try this one https://www.EnglishForward.com/user/notification-24337354.htm ? It sends me to nowhere but the home page.

Try out our live chat room.